Indeed Job Sponsorship Disruption

Incident Report for isolved

Resolved

The issue has been resolved.New indeed sponsorships are now connecting properly.
Posted May 03, 2025 - 11:31 EDT

Identified

The issue has been identified, and a fix is being implemented.
Posted May 02, 2025 - 17:18 EDT

Investigating

We’re aware of a disruption to Indeed job sponsorships beginning at 5:00 PM MST on May 1st. Our team is actively investigating and working to resolve the issue as quickly as possible. In the meantime, please hold off on sponsoring jobs until we’ve confirmed a resolution. Thank you for your patience — we’ll keep you updated.
Posted May 02, 2025 - 13:00 EDT