Benefits: Catch Up Values

Incident Report for isolved

Resolved

All services have returned to normal operation. We appreciate your patience and apologize for any inconvenience this may have caused.
Posted Apr 11, 2025 - 10:47 EDT

Investigating

Our team remains actively engaged in troubleshooting to restore services. We thank you for your understanding and will share any necessary updates as they become available.
Posted Apr 11, 2025 - 10:39 EDT

Identified

We are aware of an issue affecting our Catch-up amount values. Our team is actively investigating the issue and working diligently to restore services as quickly as possible. We will keep you updated on our progress here. Thank you for your patience!
Posted Apr 11, 2025 - 09:24 EDT