Job Ad AI Pro Outage

Incident Report for isolved

Resolved

This incident has been resolved.
Posted May 05, 2026 - 19:24 EDT

Identified

We are currently investigating an issue affecting the Job Ad AI Pro feature within iSolvedHire. This feature is unavailable at this time. Our team is actively working to restore full functionality. We apologize for the disruption and appreciate your patience.
Posted May 05, 2026 - 19:07 EDT
This incident affected: isolved People Cloud (Applicant Tracking).