This incident has been resolved. Our COBRA websites are fully accessible, and all portals have been restored for internal staff, clients, and participants.
Our team has identified and addressed the root cause. We sincerely apologize for the disruption this caused and thank you for your patience while we worked to restore service.
Posted Aug 21, 2026 - 08:52 EDT
Identified
Our team remains actively engaged in troubleshooting to restore services. We thank you for your understanding and will share any necessary updates as they become available.
Posted Aug 21, 2026 - 08:20 EDT
Investigating
We are currently experiencing an issue affecting access to Launch Pad and related COBRA websites. Some users may be unable to log in or access these portals at this time.
Our team is actively investigating the issue and working toward a resolution as quickly as possible.
We understand this disruption may affect your ability to access important services, and we appreciate your patience while we work to restore full access.
Posted Aug 21, 2026 - 07:56 EDT
This incident affected: isolved People Cloud (COBRA Launchpad).