Quarter End Reports and Treasury Bank Reconciliation Imports

Incident Report for isolved

Resolved

The issue has been identified, and a fix is being implemented after hours tonight. We appreciate your patience and apologize for any inconvenience this may have caused.
Posted Jun 27, 2025 - 10:56 EDT

Investigating

We are aware of Quarter End Reports and Treasury Bank Reconciliation Imports being unavailable or experiencing performance issues. Our team is actively investigating the issue and working diligently to restore services as quickly as possible. We will keep you updated on our progress here.  Thank you for your patience!
Posted Jun 27, 2025 - 10:33 EDT