Identified Service Interruptions: Payroll Processing

Incident Report for isolved

Resolved

All services have returned to normal operation. We appreciate your patience and apologize for any inconvenience this may have caused.
Posted Sep 01, 2026 - 10:38 EDT

Investigating

We are aware of an issue affecting the ability to commit and uncommit time cards and process payroll within isolved People Cloud in certain environments.
Our team is actively investigating and working toward resolution. We apologize for the disruption this may be causing and appreciate your patience as we work to restore full functionality. Updates will be provided as the situation progresses.
Posted Sep 01, 2026 - 10:28 EDT
This incident affected: isolved People Cloud (People Cloud).