Our team is continuing to monitor the situation to ensure full stability and normal operations. We appreciate your patience and will provide further updates as necessary.
Posted Jun 30, 2025 - 16:47 EDT
Update
Our team is continuing to monitor the situation to ensure full stability and normal operations. We appreciate your patience and will provide further updates as necessary.
Posted Jun 30, 2025 - 15:09 EDT
Update
We are continuing to monitor for any further issues.
Posted Jun 30, 2025 - 14:05 EDT
Monitoring
Our team is continuing to monitor the situation to ensure full stability and normal operations. We appreciate your patience and will provide further updates as necessary.
Posted Jun 30, 2025 - 08:00 EDT
Identified
We are aware of Applicant Tracking services being unavailable or experiencing performance issues. Our team is actively investigating the issue and working diligently to restore services as quickly as possible. We will keep you updated on our progress here. Thank you for your patience!
Posted Jun 30, 2025 - 07:54 EDT
This incident affected: isolved People Cloud (Applicant Tracking).