Identified Service Interruptions: Missing Icons in isolved People Cloud

Incident Report for isolved

Resolved

All services have returned to normal operation. We appreciate your patience and apologize for any inconvenience this may have caused.
Posted May 18, 2026 - 11:25 EDT

Update

We are continuing to investigate this issue.
Posted May 18, 2026 - 10:00 EDT

Investigating

We are aware of an issue in which icons are not rendering correctly across our platform. The root cause has been traced to an outage with our third-party icon provider.

Platform functionality is not impacted — users can continue working normally, though some visual elements may appear blank, unstyled, or as placeholder boxes until the vendor restores service.

Our teams are monitoring the vendor's recovery status and will provide updates as needed.

We apologize for any inconvenience this may cause and thank you for your patience as we work with the vendor toward resolution.
Posted May 18, 2026 - 08:45 EDT
This incident affected: isolved People Cloud (People Cloud).