Time Data Range Reports

Incident Report for isolved

Resolved

We are aware of an issue with time reports showing no data or inaccurate data for open pay periods. Our team has identified the cause and plans to deploy a hotfix tonight to restore expected functionality. As a temporary workaround clients can temporarily lock and commit the timecards, then use the Timecard Review reports dropdown to generate accurate data. After retrieving the necessary reports, they may unlock and uncommit the timecards if additional updates are needed.
We appreciate your understanding and patience as we work to resolve this issue.
Posted Oct 24, 2025 - 17:09 EDT

Identified

We are aware of an issue with time reports showing no data or inaccurate data for open pay periods. Our team has identified the cause and plans to deploy a hotfix tonight to restore expected functionality. As a temporary workaround clients can temporarily lock and commit the timecards, then use the Timecard Review reports dropdown to generate accurate data. After retrieving the necessary reports, they may unlock and uncommit the timecards if additional updates are needed.
We appreciate your understanding and patience as we work to resolve this issue.
Posted Oct 24, 2025 - 14:09 EDT