Expense Dashboard Issue
Incident Report for isolved
Resolved
Thank you for your patience. The issue has now been resolved.
Posted Nov 15, 2024 - 13:33 EST
Investigating
We are aware of an issue affecting our Expense Dashboard. Our engineers are actively troubleshooting the issue. We will share more updates as we investigate this issue. Thank you
Posted Nov 15, 2024 - 13:13 EST
This incident affected: isolved People Cloud (People Cloud).