Identified Service Interruptions: Share & Perform

Incident Report for isolved

Resolved

All services have returned to normal operation. We appreciate your patience and apologize for any inconvenience this may have caused.
Posted Feb 09, 2026 - 08:35 EST

Investigating

Share & Perform is currently experiencing an outage. Our team is actively working to restore service as quickly as possible. We will keep you updated on our progress here. Thank you for your patience!
Posted Feb 09, 2026 - 08:03 EST
This incident affected: isolved People Cloud (Share & Perform).