People Heroes University Unavailable
Incident Report for isolved
Resolved
People Heroes University has been restored. We appreciate your patience and apologize for any inconvenience this may have caused.
Posted Oct 25, 2024 - 15:30 EDT
Update
We are continuing to investigate this issue.
Posted Oct 25, 2024 - 15:11 EDT
Update
We are continuing to investigate this issue.
Posted Oct 25, 2024 - 15:10 EDT
Investigating
We are aware of People Heroes University being unavailable. Our engineers are actively troubleshooting.
Posted Oct 25, 2024 - 14:53 EDT
This incident affected: isolved People Cloud (People Heroes University).