This incident has been resolved. The intermittent "Failed to Load" error that some users encountered when accessing the Employee Absences (Time Off Balances) screen is no longer occurring.
We apologize for any disruption this caused and thank you for your patience while our team worked to address this issue.
Posted Aug 20, 2026 - 09:00 EDT
Monitoring
Our team has identified the issue and plans to deploy an update tonight. We will provide an update in the morning once testing has been completed. Thank you for your continued patience as our team works to resolve this issue.
Posted Aug 19, 2026 - 18:30 EDT
Identified
Our team remains actively engaged in troubleshooting to restore services. We thank you for your understanding and will share any necessary updates as they become available.
Posted Aug 19, 2026 - 15:51 EDT
Investigating
We are aware of an issue affecting the Employee Absences screen, where some users may intermittently encounter a "Failed to Load" error when attempting to view absence and time-off balance information. Our team has identified this issue and is actively investigating the root cause. We are working diligently to implement a permanent resolution as quickly as possible. We apologize for any disruption this may cause and appreciate your patience while we work to resolve this issue.
Posted Aug 19, 2026 - 13:49 EDT
This incident affected: isolved People Cloud (People Cloud).