Identified Service Interruptions - Notification Emails

Incident Report for isolved

Resolved

This incident has been resolved.
Posted Jul 23, 2025 - 12:28 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 23, 2025 - 10:55 EDT

Identified

We are aware of certain notification emails not being received. Our team is actively investigating the issue and working diligently to restore services as quickly as possible. We will keep you updated on our progress here. Thank you for your patience!
Posted Jul 23, 2025 - 09:56 EDT