We are keeping a close eye on the situation to ensure it remains stable. Your patience is valued, and we'll notify you promptly if further updates are needed.
Posted Jul 29, 2025 - 16:29 EDT
Update
Our team is continuing to monitor the situation to ensure full stability and normal operations. We appreciate your patience and will provide further updates as necessary.
Posted Jul 29, 2025 - 15:24 EDT
Update
We are continuing to monitor for any further issues.
Posted Jul 29, 2025 - 13:57 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 29, 2025 - 12:29 EDT
Identified
We are aware of Service Bureau emails being unavailable or experiencing performance issues. Our team is actively investigating the issue and working diligently to restore services as quickly as possible. We will keep you updated on our progress here. Thank you for your patience!
Posted Jul 29, 2025 - 11:35 EDT
This incident affected: isolved People Cloud (People Cloud).